Общие сведения о Менеджере шаблонов

Менеджер шаблонов – библиотека, предназначенная для создания, ведения и использования библиотек шаблонов при работе в КОМПАС-3D.

Применяя Менеджер шаблонов, вы сможете создать целый спектр тематических библиотек КОМПАС-3D и наполнить их необходимыми для работы объектами (шаблонами).

Разработка нового шаблона сводится к следующим этапам:

1. Создание фрагмента (детали) КОМПАС-3D.
2. Формирование в Microsoft Exсel таблицы параметров в соответствии с определенными правилами.
3. Установка связи между параметрами фрагмента (детали) КОМПАС-3D и значениями, заданными в таблице.
4. Создание схемы, содержащей имена параметров.

Готовый шаблон может быть вставлен в активный документ КОМПАС-3D. Перед тем, как вставлять шаблон, необходимо выбрать значения его параметров из ряда данных, которые содержатся в EXCEL-файле, ассоциированном с вставляемым фрагментом (деталью). Если шаблон параметризирован, то после вставки в документ значения его параметров будут соответствовать выбранным значениям переменных.

Шаблон может быть вставлен в документ КОМПАС-3D:

· как набор объектов (отрезков, дуг, кривых и т.д.);
· как нередактируемый макроэлемент;
· как редактируемый макроэлемент.

Если шаблон будет вставлен в документ КОМПАС-3D как редактируемый макроэлемент, то впоследствии его можно будет отредактировать штатными средствами библиотеки Менеджер шаблонов.

Для работы Менеджера шаблонов необходимо наличие на вашем компьютере установленной программы Microsoft EXCEL 2000 или Microsoft EXCEL 97.


Главное окно

Менеджера шаблонов – стандартное приложение Windows. Его главное окно содержит ряд атрибутов приложений Windows:

· заголовок окна;
· строку главного меню;
· пиктограммы минимизации, максимизации и закрытия окна;
· рамку для изменения размеров окна.

Окно Менеджера шаблонов разделено на несколько рабочих зон:
· дерево шаблонов;
· изображение шаблона или схема параметров шаблона;
· комментарий;
· таблица переменных.

Информация, содержащаяся в рабочих зонах, взаимосвязана. Она определяется тем, какой элемент выбран или выделен цветом в дереве шаблонов. Вы всегда будете видеть изображение того шаблона, который выделен в дереве цветом, а таблицу переменных сможете увидеть только для того шаблона, который выбран в дереве.

Вы можете менять размеры областей, перемещая границы между ними при помощи мыши. Используя разделительные линейки, которые находятся на границе областей, можно закрывать и раскрывать все области, кроме дерева шаблонов.

На панели инструментов главного окна Менеджера шаблонов расположены кнопки вызова команд, которые наиболее часто используются при работе с библиотекой.

Под таблицей переменных находится строка состояния. Она разделена на две части. В левой части приведено полное имя выделенного элемента библиотеки, в правой – полное имя выбранного шаблона. Дважды щелкните мышью по строке состояния, чтобы перейти в дереве к выбранному шаблону.

Информацию об основных элементах интерфейса главного окна вы можете получить, если щелчком мыши укажете на иллюстрации интересующий вас элемент.

Вы можете изменить оформление (цвет, шрифты), а также ряд других свойств главного окна. Для этого вызовите со страницы главного меню Сервис команду Настройка или нажмите клавиши <Shift>+<S>.


Главное меню

Главное меню содержит шесть страниц:

· Библиотека;
· Правка;
· Поиск;
· Вид;
· Сервис;
· ? (справка).

На каждой странице находятся команды, объединенные в группы по функциональному признаку.

Для запуска какой-либо команды щелкните мышью на названии страницы меню, затем на строке с названием команды. Между разделами и командами меню можно перемещаться с помощью клавиш со стрелками и выбирать команды нажатием клавиши <Enter>.

Для ряда команд справа от названия указаны так называемые «горячие клавиши». С их помощью вы сможете вызывать эти команды, не обращаясь к меню.


Дерево шаблонов

Дерево шаблонов включает в себя разделы и шаблоны текущей библиотеки шаблонов. Оно предназначено:

· для навигации по структуре библиотеки;
· для отображения информации о библиотеке, ее разделах и шаблонах;
· для выбора шаблона, который нужно посмотреть, вставить в документ КОМПАС-3D, отредактировать или удалить.

В дереве шаблонов может быть показана следующая дополнительная информация:

· наименование директории, где хранится библиотека;
· название файла КОМПАС-3D, в котором хранитcя фрагмент (деталь) шаблона;
· название файла Microsoft EXCEL, в котором хранится таблица параметров шаблона;
· название файла, в котором хранится схема параметров шаблона или заставка библиотеки.

Каждый дополнительный параметр будет показан отдельным столбцом рядом с деревом шаблонов. Чтобы отобразить (скрыть) в дереве тот или иной дополнительный параметр, воспользуйтесь командами страницы главного меню Вид.

Управление элементами дерева шаблонов осуществляется при помощи команд главного меню и кнопок панели инструментов окна Менеджера шаблонов. Кроме того, для разделов и шаблонов в дереве шаблонов существует контекстное меню. Кроме команд, перечисленных в главном меню, оно содержит команды управления буфером обмена:

· Вырезать;
· Копировать;
· Вставить.

С помощью этих команд вы сможете создавать полные копии разделов и шаблонов.

Используя механизм Drag&Drop, вы имеете возможность:

· перемещать шаблоны и разделы библиотеки по дереву шаблонов; для этого:
- укажите элемент библиотеки курсором;
- удерживая левую клавишу мыши, переместите элемент на новое место;
- отпустите клавишу мыши;

· копировать шаблоны и разделы библиотеки; для этого:
- укажите элемент библиотеки курсором;
- нажмите клавишу <Ctrl> и, удерживая левую клавишу мыши, переместите курсор в то место, где будет находиться копия;
- отпустите клавишу мыши.


Панель инструментов окна Менеджера шаблонов

Панель инструментов окна Менеджера шаблонов содержит кнопки вызова команд, которые наиболее часто используются при работе с библиотекой.

Каждая кнопка соответствует какой-либо команде. Для запуска команды подведите курсор к кнопке и щелкните по ней мышью.

Доступность кнопок панели инструментов зависит от того, какой элемент библиотеки выбран в дереве шаблонов.


Панель инструментов таблицы переменных

Панель инструментов таблицы переменных появляется только при одновременном выполнении двух условий:
· в дереве шаблонов выбран шаблон;
· в КОМПАС-3D открыт документ, соответствующий типу шаблона (для двухмерного шаблона – фрагмент или чертеж, для трехмерного шаблона – деталь или сборка).

Набор кнопок на панели инструментов для двухмерных шаблонов отличается от набора кнопок на панели инструментов для трехмерных шаблонов.

Панель инструментов таблицы параметров двухмерного шаблона содержит кнопки, предназначенные для восстановления исходных значений параметров шаблона и для выбора способа вставки фрагмента в документ КОМПАС-3D.

Панель инструментов таблицы параметров трехмерного шаблона содержит кнопки, предназначенные для восстановления исходных значений параметров шаблона и для выбора способа вставки детали в документ КОМПАС-3D.


Настройка

Команда Настройка предназначена для изменения свойств:

· главного окна Менеджера шаблонов;
· шаблонов.

Чтобы начать настройку, вызовите со страницы главного меню Сервис команду Настройка или нажмите клавиши <Shift>+<S>. В открывшемся окне задайте свойства главного окна. Если необходимо установить параметры работы с шаблонами, нажмите кнопку Свойства шаблонов.


Настройка свойств окна Менеджера шаблонов

Окно Настройка предназначено для изменения следующих свойств окна Менеджера шаблонов:

· поведение (состояние окна при вставке и после вставки шаблона);
· цвет (цвет фона основных элементов интерфейса);
· шрифт (тип шрифта в основных рабочих зонах Менеджера шаблонов);
· разделители (определение рабочих зон, которые могут быть скрыты при помощи разделительных линеек).

Смотрите также:
_______________________________________________________

Настройка свойств шаблонов.


Поведение

Чтобы определить состояние окна Менеджера шаблонов при вставке и после вставки шаблона, сделайте следующее.

1. Вызовите со страницы главного меню Сервис команду Настройка или нажмите клавиши <Shift>+<S>.

Откроется окно Настройка.

2. На панели Свойства главного окна нажмите на значок «+», расположенный слева от названия параметра Поведение.

Раскроется список возможных вариантов поведения окна Менеджера шаблонов.

3. Щелчком мыши выберите нужные варианты.

4. Чтобы подтвердить выбор, нажмите кнопку ОК, чтобы отказаться от выбора – кнопку Отмена.

Смотрите также:
_______________________________________________________

Цвет;
Шрифт;
Разделители.


Цвет

Чтобы определить цвет фона основных рабочих зон окна Менеджера шаблонов, сделайте следующее.

1. Вызовите со страницы главного меню Сервис команду Настройка или нажмите клавиши <Shift>+<S>.

Откроется окно Настройка.

2. На панели Свойства главного окна нажмите на значок «+», расположенный слева от названия параметра Цвет.

Раскроется список основных рабочих зон окна Менеджера шаблонов.

3. Щелкните мышью в поле, где указан цвет интересующей вас зоны.

4. Нажмите появившуюся кнопку с черным треугольником и выберите цвет зоны из раскрывшегося списка.

5. Вы можете назначить произвольный цвет зоны. Для этого выберите последнюю в списке цветов строку «Custom Color...», а затем укажите нужный цвет на дополнительной палитре.

6. Чтобы подтвердить выбор, нажмите кнопку ОК, чтобы отказаться от выбора – кнопку Отмена.

Смотрите также:
_______________________________________________________

Поведение;
Шрифт;
Разделители.


Шрифт

Чтобы определить шрифт для основных рабочих зон окна Менеджера шаблонов, сделайте следующее.

1. Вызовите со страницы главного меню Сервис команду Настройка или нажмите клавиши <Shift>+<S>.

Откроется окно Настройка.

2. На панели Свойства главного окна нажмите на значок «+», расположенный слева от названия параметра Шрифт.

Раскроется список основных рабочих зон окна Менеджера шаблонов.

3. Щелкните мышью в поле, где указан шрифт, используемый в интересующей вас зоне.

Откроется стандартное окно для установки параметров шрифтов.

4. Выберите шрифт и его характеристики. Нажмите кнопку OK.

5. Чтобы подтвердить выбор, нажмите кнопку ОК, чтобы отказаться от выбора – кнопку Отмена.

Смотрите также:
_______________________________________________________

Поведение;
Цвет;
Разделители.


Разделители

Чтобы определить, какие рабочие зоны окна Менеджера шаблонов будут сворачиваться при использовании разделительных линеек,
сделайте следующее.

1. Вызовите со страницы главного меню Сервис команду Настройка или нажмите клавиши <Shift>+<S>.

Откроется окно Настройка.

2. На панели Свойства главного окна нажмите на значок «+», расположенный слева от названия параметра Разделители.

Раскроется список основных пар рабочих зон окна Менеджера шаблонов, между которыми есть разделительные линейки.

3. Щелкните мышью в поле, где указано значение параметра.

4. Нажмите появившуюся кнопку с черным треугольником и выберите значение из раскрывшегося списка. Оно указывает направление вершин треугольников разделительной линейки. («Вправо» – первая зона в паре буде раскрыта на ширину окна за счет сворачивания второй зоны в паре и т.д.)

5. Чтобы подтвердить выбор, нажмите кнопку ОК, чтобы отказаться от выбора – кнопку Отмена.

Смотрите также:
_______________________________________________________

Поведение;
Цвет;
Шрифт.


Настройка свойств шаблонов

Окно Настройка предназначено для изменения следующих свойств библиотечных шаблонов:

Свойства параметризации:

· количество итераций;
· использование библиотеки моделей;
· типы переменных в EXCEL;
· видимость колонок в EXCEL;
· названия объектов КОМПАС;
· варианты ввода значений.

Свойства спецификации:

· объект спецификации;
· редактировать;
· номер блока (раздела) спецификации;
· номер колонки.

Смотрите также:
_______________________________________________________

Настройка свойств окна Менеджера шаблонов.


Количество итераций

При замене ранее введенного значения параметра шаблона на значение, выбранное из таблиц Microsoft EXCEL, пересчет и перестроение модели происходит за несколько этапов – итераций. Чем больше количество итераций, тем плавнее (но медленнее) происходит замена. Если количество итераций слишком мало, то при значительном изменении значения параметра может произойти сбой в работе программы. Рекомендуемое количество итераций (предлагается по умолчанию) – 10.

Чтобы изменить количество итераций, сделайте следующее.

1. Вызовите со страницы главного меню Сервис команду Настройка или нажмите клавиши <Shift>+<S>. Откроется окно Настройка.

2. Выберите панель Свойства шаблонов. Затем нажмите на значок «+», расположенный слева от узла Параметризация. В окне появится строка Количество итераций.

3. Измените значение параметра с помощью клавиатуры или появившейся кнопки-счетчика.

4. Чтобы подтвердить изменение значения параметра, нажмите кнопку ОК, чтобы отказаться от изменения – кнопку Отмена.

Смотрите также:
_______________________________________________________

Типы переменных в EXCEL;
Видимость колонок в EXCEL;
Названия объектов КОМПАС;
Варианты ввода значений;
Объект спецификации;
Редактировать объект спецификации;
Раздел спецификации;
Номер колонки объекта спецификации.


Использование библиотеки моделей

Вы можете вставлять трехмерный шаблон в документ КОМПАС (команда Вставить редактируемый библиотечный элемент):
· либо из файла;
· либо из КОМПАС-Библиотеки моделей (l3d).

В первом случае файл-источник вставленного в сборку шаблона будет находиться в директории сборки, и каждый экземпляр такого шаблона будет ссылаться на свой файл. Сколько экземпляров шаблона вы вставите в сборку, столько файлов будет создано в директории сборки.

Во втором случае файл-источник вставленного в сборку шаблона будет находиться в КОМПАС-Библиотеке моделей. Эта библиотека моделей будет автоматически создана в директории библиотеки шаблонов, с которой в данный момент работает пользователь. При этом несколько экземпляров шаблона, вставленных в сборку, будут ссылаться на один и тот же файл в КОМПАС-Библиотеке моделей.

Второй режим установлен по умолчанию. Чтобы выбрать первый режим, сделайте следующее.

1. Вызовите со страницы главного меню Сервис команду Настройка или нажмите клавиши <Shift>+<S>. Откроется окно Настройка.

2. Выберите панель Свойства шаблонов. Затем нажмите на значок «+», расположенный слева от узла Параметризация. В окне появится строка Использовать библиотеки моделей.

3. Щелчком мыши снимите флажок рядом с наименованием параметра. Значение параметра будет заменено на «Нет».

4. Чтобы подтвердить изменение значения параметра, нажмите кнопку ОК, чтобы отказаться от изменения – кнопку Отмена.

Для перехода обратно ко второму режиму, выполните действия, описанные в пп. 1 и 2, затем щелчком мыши установите флажок рядом с наименованием параметра. Значение параметра будет заменено на «Да».

Смотрите также:
_______________________________________________________

Типы переменных в EXCEL;
Видимость колонок в EXCEL;
Названия объектов КОМПАС;
Варианты ввода значений;
Объект спецификации;
Редактировать объект спецификации;
Раздел спецификации;
Номер колонки объекта спецификации.


Типы переменных в EXCEL

В пятой строке таблицы переменных параметров Microsoft EXCEL, ассоциированной с фрагментом (деталью), указывается тип используемой переменной.

Каждому типу переменной соответствует определенный идентификатор.

Вы можете установить свои идентификаторы на типы переменных. Для этого сделайте следующее.

1. Вызовите со страницы главного меню Сервис команду Настройка или нажмите клавиши <Shift>+<S>.

Откроется окно Настройка.

2. Выберите панель Свойства шаблонов. Затем нажмите на значок «+», расположенный слева от узла Параметризация.

3. Раскройте узел Типы переменных в ЕXСEL.

Вы увидите идентификаторы, которые в данный момент применяются для обозначения определенных типов переменных.

4. С помощью клавиатуры введите свои идентификаторы типов переменных.

5. Чтобы подтвердить изменение значений параметров, нажмите кнопку ОК, чтобы отказаться от изменений – кнопку Отмена.

Смотрите также:
_______________________________________________________

Количество итераций;
Видимость колонок в EXCEL;
Названия объектов КОМПАС;
Варианты ввода значений;
Объект спецификации;
Редактировать объект спецификации;
Раздел спецификации;
Номер колонки объекта спецификации.


Видимость колонок в EXCEL

В четвертой строке таблицы переменных параметров Microsoft EXCEL, ассоциированной с фрагментом (деталью), указывается флаг видимости колонок. Это признак, отвечающий за то, видна ли будет колонка в таблице переменных, которая отображается в главном окне Менеджера шаблонов.

Колонка может быть:
· видима всегда;
· невидима всегда;
· видима по условию (если есть во фрагменте или в детали – то видна и в таблице).

Каждому флагу видимости соответствует определенный идентификатор. Вы можете установить свои идентификаторы флагов видимости. Для этого сделайте следующее.

1. Вызовите со страницы главного меню Сервис команду Настройка или нажмите клавиши <Shift>+<S>.

Откроется окно Настройка.

2. Выберите панель Свойства шаблонов. Затем нажмите на значок «+», расположенный слева от узла Параметризация.

3. Раскройте узел Видимость колонок в ЕXСEL.

Вы увидите идентификаторы, которые в данный момент применяются для обозначения флагов видимости.

4. С помощью клавиатуры введите свои идентификаторы флагов видимости колонок.

5. Чтобы подтвердить изменение значений параметров, нажмите кнопку ОК, чтобы отказаться от изменений – кнопку Отмена.

Смотрите также:
_______________________________________________________

Количество итераций;
Типы переменных в EXCEL;
Названия объектов КОМПАС;
Варианты ввода значений;
Объект спецификации;
Редактировать объект спецификации;
Раздел спецификации;
Номер колонки объекта спецификации.


Названия объектов КОМПАС

При создании графического фрагмента двухмерного шаблона могут быть использованы объекты с предопределенными свойствами. Такие объекты отмечаются специальными идентификаторами, оговоренными в настройке свойств шаблона. К рассматриваемым объектам относятся:

· Удаляемый слой. Это слой, который будет обязательно ликвидирован при вставке шаблона в документ КОМПАС-3D. Для того чтобы слой был удаляемым, его имя обязательно должно содержать определенный идентификатор (по умолчанию – DELETING_LAYER), заключенный между двумя символами #.

· Слой – граница очистки. При вставке шаблона в документ КОМПАС-3D все уже существующие графические объекты, которые попадут внутрь области, ограниченной графическими объектами этого слоя, будут удалены. Для того чтобы слой был границей очистки, его имя обязательно должно содержать определенный идентификатор (по умолчанию – CLEAR_LAYER), заключенный между двумя символами #.

· Базовая точка. Это точка за которую шаблон при вставке будет «привязан» к объектам документа КОМПАС-3D. Такой точке должен быть присвоен атрибут «Базовая точка». Значением атрибута должен являться номер точки. В таблице EXCEL может присутствовать переменная, значение которой есть номер базовой точки. Идентификатор этой переменной по умолчанию – BASE_POINT.

Вы можете изменить идентификаторы таких объектов КОМПАС. Для этого сделайте следующее.

1. Вызовите со страницы главного меню Сервис команду Настройка или нажмите клавиши <Shift>+<S>.

Откроется окно Настройка.

2. Выберите панель Свойства шаблонов. Затем нажмите на значок «+», расположенный слева от узла Параметризация.

3. Раскройте узел Названия объектов КОМПАС.

Вы увидите идентификаторы, которые в данный момент применяются для объектов КОМПАС.

4. С помощью клавиатуры введите свои идентификаторы названий объектов КОМПАС.

5. Чтобы подтвердить изменение значений параметров, нажмите кнопку ОК, чтобы отказаться от изменений – кнопку Отмена.

Смотрите также:
_______________________________________________________

Количество итераций;
Типы переменных в EXCEL;
Видимость колонок в EXCEL;
Варианты ввода значений;
Объект спецификации;
Редактировать объект спецификации;
Раздел спецификации;
Номер колонки объекта спецификации.


Варианты ввода значений

В шестой строке таблицы переменных параметров Microsoft EXCEL, ассоциированной с фрагментом (деталью), указываются идентификаторы вариантов ввода значения параметров.

Варианты ввода могут быть такими:

· Константа;
· Диапазон;
· Диапазон, ограниченный снизу;
· Диапазон, ограниченный сверху;
· Галочка;
· Ниспадающий список;
· Значение по умолчанию.

Каждому варианту соответствует определенный идентификатор по умолчанию. Вы можете заменить предлагаемые идентификаторы на свои. Для этого сделайте следующее.

1. Вызовите со страницы главного меню Сервис команду Настройка или нажмите клавиши <Shift>+<S>.

Откроется окно Настройка.

2. Выберите панель Свойства шаблонов. Затем нажмите на значок «+», расположенный слева от узла Параметризация.

3. Раскройте узел Варианты ввода значений.

Вы увидите идентификаторы, которые в данный момент применяются для обозначения вариантов ввода значений.

4. С помощью клавиатуры введите свои идентификаторы.

5. Чтобы подтвердить изменение значений параметров, нажмите кнопку ОК, чтобы отказаться от изменений – кнопку Отмена.

Смотрите также:
_______________________________________________________

Количество итераций;
Типы переменных в EXCEL;
Видимость колонок в EXCEL;
Названия объектов КОМПАС;
Объект спецификации;
Редактировать объект спецификации;
Раздел спецификации;
Номер колонки объекта спецификации.


Объект спецификации

При вставке шаблона в документ КОМПАС-3D автоматически может быть создан объект спецификации. Чтобы иметь возможность управлять созданием объекта спецификации, необходимо в таблице EXCEL ввести переменную, имеющую соответствующий идентификатор (по умолчанию – SPC_OBJECT). Если значение этой переменной установить равным 1, то объект спецификации будет создаваться, если 0 – то нет.

Вы можете изменить идентификатор объекта спецификации. Для этого сделайте следующее.

1. Вызовите со страницы главного меню Сервис команду Настройка или нажмите клавиши <Shift>+<S>.

Откроется окно Настройка.

2. Выберите панель Свойства шаблонов. Затем нажмите на значок «+», расположенный слева от узла Спецификация.

В окне появится строка Объект спецификации.

3. С помощью клавиатуры введите новый идентификатор.

4. Чтобы подтвердить изменение значения параметра, нажмите кнопку ОК, чтобы отказаться от изменения – кнопку Отмена.

Смотрите также:
_______________________________________________________

Количество итераций;
Типы переменных в EXCEL;
Видимость колонок в EXCEL;
Названия объектов КОМПАС;
Варианты ввода значений;
Редактировать объект спецификации;
Раздел спецификации;
Номер колонки объекта спецификации.


Редактировать объект спецификации

При вставке шаблона в документ КОМПАС-3D может быть открыто окно редактирования объекта спецификации:

Чтобы реализовать такую возможность, необходимо в таблице EXCEL ввести переменную, имеющую соответствующий идентификатор (по умолчанию – SPC_OBJECT_EDIT). Если значение этой переменной установить равным 1, то при вставке шаблона будет открываться окно Объект спецификации, если 0 – то нет.

Вы можете изменить идентификатор, отвечающий за вызов окна Объект спецификации. Для этого сделайте следующее.

1. Вызовите со страницы главного меню Сервис команду Настройка или нажмите клавиши <Shift>+<S>.

Откроется окно Настройка.

2. Выберите панель Свойства шаблонов. Затем нажмите на значок «+», расположенный слева от узла Спецификация.

В окне появится строка Редактировать.

3. С помощью клавиатуры введите новый идентификатор.

4. Чтобы подтвердить изменение значения параметра, нажмите кнопку ОК, чтобы отказаться от изменения – кнопку Отмена.

Смотрите также:
_______________________________________________________

Количество итераций;
Типы переменных в EXCEL;
Видимость колонок в EXCEL;
Названия объектов КОМПАС;
Варианты ввода значений;
Объект спецификации;
Раздел спецификации;
Номер колонки объекта спецификации.


Номер блока (раздела) спецификации

При работе с Менеджером шаблонов можно выбирать раздел спецификации, в который будет помещен объект, созданный при вставке шаблона.

Для этого необходимо в таблице EXCEL ввести переменную, имеющую соответствующий идентификатор (по умолчанию – SPC_BLOCK). Значение этой переменной определит номер раздела спецификации, в который будет помещен созданный объект.

Если такой переменной в таблице EXCEL не будет, то по умолчанию создаваемый объект спецификации будет помещен в раздел с номером 25 («Стандартные изделия» в «Простой спецификация ГОСТ 2.106–96» библиотеки graphit.lyt ).

Вы можете изменить идентификатор, отвечающий за выбор номера раздела спецификации. Для этого сделайте следующее.

1. Вызовите со страницы главного меню Сервис команду Настройка или нажмите клавиши <Shift>+<S>.

Откроется окно Настройка.

2. Выберите панель Свойства шаблонов. Затем нажмите на значок «+», расположенный слева от узла Спецификация.

В окне появится строка Номер блока.

3. С помощью клавиатуры введите новый идентификатор.

4. Чтобы подтвердить изменение значения параметра, нажмите кнопку ОК, чтобы отказаться от изменения – кнопку Отмена.

Смотрите также:
_______________________________________________________

Количество итераций;
Типы переменных в EXCEL;
Видимость колонок в EXCEL;
Названия объектов КОМПАС;
Варианты ввода значений;
Объект спецификации;
Редактировать объект спецификации;
Номер колонки объекта спецификации.


Номер колонки объекта спецификации

При работе с Менеджером шаблонов можно указать колонку спецификации, в которую будет помещено значение, указанное в таблице EXCEL.

Для этого необходимо в таблице EXCEL ввести переменную, имеющую соответствующий идентификатор (по умолчанию – SPC_COL_) + номер колонки.

Например, колонока «Обозначение» из «Простой спецификации ГОСТ 2.106–96» библиотеки graphit.lyt имеет номер 4. Чтобы вставить в эту колонку определенное значение, в таблице EXCEL необходимо ввести переменную SPC_COL_4. Значение этой переменной будет перенесено в спецификацию, в колонку «Обозначение».

Вы можете изменить идентификатор, отвечающий за выбор номера колонки в спецификации. Для этого сделайте следующее.

1. Вызовите со страницы главного меню Сервис команду Настройка или нажмите клавиши <Shift>+<S>.

Откроется окно Настройка.

2. Выберите панель Свойства шаблонов. Затем нажмите на значок «+», расположенный слева от узла Спецификация.

В окне появится строка Номер колонки.

3. С помощью клавиатуры введите новый идентификатор.

4. Чтобы подтвердить изменение значения параметра, нажмите кнопку ОК, чтобы отказаться от изменения – кнопку Отмена.

Смотрите также:
_______________________________________________________

Количество итераций;
Типы переменных в EXCEL;
Видимость колонок в EXCEL;
Названия объектов КОМПАС;
Варианты ввода значений;
Объект спецификации;
Редактировать объект спецификации;
Раздел спецификации.


Алгоритм создания новой библиотеки

Если вы хотите при помощи Менеджера шаблонов создать новую библиотеку, придерживайтесь следующей последовательности действий.

1. Подготовьте в КОМПАС-3D двухмерные фрагменты и (или) трехмерные модели (детали) конструктивных элементов, которые будут храниться в библиотеке. По возможности старайтесь дать созданным файлам имена, говорящие о содержании файлов.

2. Создайте схемы переменных параметров фрагментов (деталей).

3. Создайте в Microsoft EXCEL таблицы переменных для подготовленных фрагментов (деталей). По возможности старайтесь дать созданным таблицам имена, которые впоследствии помогут ассоциировать их с соответствующими фрагментами (моделями).

4. Запустите Менеджер шаблонов.

5. Вызовите команду Новая библиотека и укажите название и месторасположение библиотеки. При необходимости укажите файл, который будет использоваться в качестве заставки к библиотеке.

6. При помощи команды Создать раздел оформите структуру библиотеки – создайте нужные разделы и подразделы, в которых будут храниться шаблоны.

7. Используя команду Создать шаблон, наполните библиотеку шаблонами, устанавливая связи фрагментов (деталей), таблиц переменных и схем переменных параметров.

8. Сохраните созданную библиотеку.

Смотрите также:
_______________________________________________________

Алгоритм редактирования существующей библиотеки;
Алгоритм вставки готового библиотечного шаблона.


Алгоритм редактирования существующей библиотеки

Если вы хотите внести изменения в существующую библиотеку шаблонов, придерживайтесь следующей последовательности действий.

1. Запустите Менеджер шаблонов и откройте нужную библиотеку.

2. Если необходимо внести изменения в структуру библиотеки, воспользуйтесь командами Создать раздел, Создать шаблон и Удалить элемент библиотеки. Для копирования элементов библиотеки применяйте команды управления буфером обмена и используйте возможности, которые предоставляет использование механизма Drag&Drop в дереве шаблонов. Вы можете скопировать в редактируемую библиотеку разделы из другой библиотеки шаблонов. Для этого воспользуйтесь командой Добавить библиотеку.

3. Вы можете перейти в режим редактирования таблицы переменных или фрагмента (детали) указанного шаблона, воспользовавшись, соответственно командами Редактировать таблицу EXCEL и Редактировать файл КОМПАС-3D.

4. Чтобы установить в шаблонах новые связи фрагментов (деталей), таблиц переменных и схем переменных параметров, применяйте к указанному шаблону команду Редактировать элемент библиотеки.

5. Используйте команду Редактировать элемент библиотеки для раздела или для библиотеки, чтобы изменить атрибуты указанного элемента.

6. Для поиска и замены фрагментов текста, входящих в наименования элементов библиотеки, пользуйтесь командами Поиск и Замена.

7. Сохраните отредактированную библиотеку или создайте ее копию.

Смотрите также:
_______________________________________________________

Алгоритм создания новой библиотеки;
Алгоритм вставки готового библиотечного шаблона.


Алгоритм вставки готового библиотечного шаблона

При вставке готового библиотечного шаблона в документ КОМПАС-3D придерживайтесь следующей последовательности действий.

1. Запустите КОМПАС-3D и документ, в который нужно вставить библиотечный шаблон.

2. Запустите Менеджер шаблонов и откройте нужную библиотеку.

3. Найдите и выберите нужный шаблон.

4. Присвойте значения переменным параметрам шаблона.

5. Нажмите на панели инструментов таблицы переменных кнопку, которая соответствует необходимому способу вставки двухмерного или трехмерного шаблона.

Смотрите также:
_______________________________________________________

Алгоритм создания новой библиотеки;
Алгоритм редактирования существующей библиотеки.


Завершение работы Менеджера шаблонов

Чтобы завершить работу с библиотекой Менеджер шаблонов, выполните одно из следующих действий:

1. Нажмите на панели инструментов окна Менеджера шаблонов кнопку Выход.

2. Вызовите команду Выход со страницы главного меню Библиотека.

3. Нажмите клавиши <Ctrl>+<X>.

4. Нажмите кнопку, которая расположена в правом верхнем углу окна Менеджера шаблонов.

Перед завершением работы Менеджера шаблонов запоминается состояние главного окна библиотеки. В следующем сеансе работы с библиотекой это состояние будет восстановлено.


Управление библиотеками шаблонов

Управление библиотеками шаблонов осуществляется при помощи команд, расположенных на странице главного меню Библиотека:

· Новая;
· Открыть;
· Закрыть;
· Сохранить;
· Сохранить как...

и команд, расположенных на странице главного меню Сервис:

· Добавить библиотеку;
· Сформировать библиотеку.

Ряд команд (Новая, Открыть, Сохранить) могут быть вызваны при помощи соответствующих кнопок панели инструментов главного окна Менеджера шаблонов.


Создание библиотеки

Команда Новая предназначена для создания новой библиотеки шаблонов.

Перед тем, как создавать новую библиотеку шаблонов, создайте отдельную директорию (лучше – внутри директории TemplateManager), где будут размещаться все ее элементы. Это позволит упорядочить дальнейшую работу с библиотеками шаблонов.

1. Вызовите команду Новая со страницы главного меню Библиотека или нажмите соответствующую кнопку на панели инструментов окна Менеджера шаблонов.
кнопка Новая библиотека.

Откроется окно Новая библиотека.

2. В поле Директория библиотеки нажмите кнопку с черным треугольником и укажите каталог, где будет размещена новая библиотека.

3. В поле Имя библиотеки введите название создаваемой библиотеки.

4. В поле Заставка укажите имя файла, который будет использоваться в качестве заставки к библиотеке. Для этого нажмите кнопку Открыть, расположенную справа от поля ввода.

кнопка Открыть.

В открывшемся стандартном диалоге Windows укажите имя файла (он должен обязательно находиться в вышеуказанной директории), и нажмите кнопку Открыть. Заставка не является обязательным атрибутом библиотеки и может отсутствовать.

5. В окне Новая библиотека нажмите кнопку ОК.

6. В окне Менеджера шаблонов введите комментарий – краткую информацию о созданной библиотеке.

Смотрите также:
_______________________________________________________

Открытие библиотеки;
Закрытие библиотеки;
Сохранение библиотеки;
Сохранение копии библиотеки;
Добавление новой библиотеки в существующую;
Формирование библиотеки.


Редактирование атрибутов библиотеки

Команда Редактировать элемент библиотеки поможет вам изменить атрибуты библиотеки (месторасположение, название и используемый для заставки файл).

Чтобы команда Редактировать элемент библиотеки была доступна, в дереве не должен быть выбран ни один шаблон.

1. Курсором укажите название библиотеки в дереве шаблонов.

2. Вызовите команду Редактировать элемент библиотеки со страницы главного меню Правка или нажмите соответствующую кнопку на панели инструментов окна Менеджера шаблонов.
кнопка Редактировать элемент библиотеки.

Откроется окно Редактировать библиотеку.

3. Чтобы изменить месторасположение библиотеки, в поле Директория библиотеки нажмите кнопку с черным треугольником и выберите другой каталог, где будет размещена библиотека.

4. Чтобы переименовать библиотеку, в поле Имя библиотеки введите ее новое название.

5. Чтобы заменить файл заставки к библиотеке, в поле Заставка нажмите кнопку Открыть и в открывшемся стандартном диалоге Windows укажите имя другого файла с заставкой (файл должен обязательно находиться в директории, указанной в поле Директория библиотеки), а затем нажмите кнопку OK.

кнопка Открыть.

Заставка не является обязательным атрибутом библиотеки и может отсутствовать.

6. В окне Редактировать библиотеку нажмите кнопку ОК.

7. При необходимости в окне Менеджера шаблонов измените краткую информацию о библиотеке – отредактируйте комментарий.


Открытие библиотеки

Команда Открыть предназначена для начала работы с существующей библиотекой шаблонов.

1. Вызовите команду Открыть со страницы главного меню Библиотека или нажмите соответствующую кнопку на панели инструментов окна Менеджера шаблонов.
кнопка Открыть.

2. В открывшемся стандартном диалоге Windows укажите имя файла библиотеки (файл формата *.tlm) и нажмите кнопку Открыть.

Если в текущем сеансе работы с Менеджером шаблонов вы уже открывали библиотеки шаблонов, на панели инструментов справа от кнопки Открыть появится кнопка с черным треугольником. Нажав эту кнопку, вы увидите список ранее открывавшихся библиотек. Чтобы вновь открыть одну из этих них, достаточно щелкнуть мышью на ее названии.

Смотрите также:
_______________________________________________________

Создание библиотеки;
Закрытие библиотеки;
Сохранение библиотеки;
Сохранение копии библиотеки;
Добавление новой библиотеки в существующую;
Формирование библиотеки.


Закрытие библиотеки

Команда Закрыть предназначена для завершения работы с открытой библиотекой шаблонов.

1. Вызовите команду Закрыть со страницы главного меню Библиотека или нажмите клавиши <Shift>+<S>.

Все рабочие зоны главного окна Менеджера шаблонов будут очищены.

Смотрите также:
_______________________________________________________

Создание библиотеки;
Открытие библиотеки;
Сохранение библиотеки;
Сохранение копии библиотеки;
Добавление новой библиотеки в существующую;
Формирование библиотеки.


Сохранение библиотеки

Команда Сохранить предназначена для сохранения открытой библиотекой шаблонов.

1. Вызовите команду Сохранить со страницы главного меню Библиотека или нажмите соответствующую кнопку на панели инструментов окна Менеджера шаблонов.
кнопка Сохранить.

2. Если вы сохраняете новую библиотеку, откроется стандартный диалог Windows, в котором нужно дать библиотеке имя, указать ее месторасположение, а затем нажать кнопку Сохранить.

3. Если вы сохраняете библиотеку, которая уже имеет название, она будет обновлена без дополнительных сообщений.

Смотрите также:
_______________________________________________________

Создание библиотеки;
Открытие библиотеки;
Закрытие библиотеки;
Сохранение копии библиотеки;
Добавление новой библиотеки в существующую;
Формирование библиотеки.


Сохранение копии библиотеки

Команда Сохранить как... предназначена для сохранения открытой библиотеки шаблонов под другим именем или в другой директории.

1. Вызовите команду Сохранить как... со страницы главного меню Библиотека.

2. В открывшемся стандартном диалоге Windows введите новое имя библиотеки или укажите ее новое месторасположение. Затем нажмите кнопку Сохранить.

Смотрите также:
_______________________________________________________

Создание библиотеки;
Открытие библиотеки;
Закрытие библиотеки;
Сохранение библиотеки;
Добавление новой библиотеки в существующую;
Формирование библиотеки.


Добавление новой библиотеки в существующую

Команда Добавить библиотеку предназначена для вставки существующей библиотеки шаблонов в открытую библиотеку шаблонов в качестве нового раздела открытой библиотеки.

Чтобы команда Добавить библиотеку была доступна, в дереве не должен быть выбран ни один шаблон.

1. В дереве шаблонов укажите курсором тот элемент (шаблон или раздел), после которого нужно вставить новый раздел.

2. Вызовите команду Добавить библиотеку со страницы главного меню Сервис или нажмите клавиши <Ctrl>+<L>.

Откроется окно, в котором нужно будет указать месторасположение добавляемой библиотеки шаблонов.

3. В окне Добавить библиотеку нажмите кнопку Открыть, расположенную справа от поля ввода названия библиотеки.
кнопка Открыть.

В открывшемся стандартном диалоге Windows укажите библиотеку шаблонов (файл формата *.tlm), которую нужно добавить в открытую библиотеку. Затем нажмите кнопку Открыть.

4. В окне Добавить библиотеку нажмите кнопку ОК.

В дереве шаблонов появятся новые элементы.

Смотрите также:
_______________________________________________________

Создание библиотеки;
Открытие библиотеки;
Закрытие библиотеки;
Сохранение библиотеки;
Сохранение копии библиотеки;
Формирование библиотеки.


Формирование библиотеки

Команда Сформировать библиотеку предназначена для создания новой библиотеки шаблонов на базе указанного элемента (шаблона, раздела) открытой библиотеки шаблонов.

Чтобы команда Сформировать библиотеку была доступна, в дереве не должен быть выбран ни один шаблон.

1. В дереве шаблонов укажите курсором тот элемент (шаблон или раздел), из которого нужно сформировать новую библиотеку.

2. Вызовите команду Сформировать библиотеку со страницы главного меню Сервис или нажмите клавиши <Shift>+<L>.

В открывшемся стандартном диалоге Windows, введите имя и укажите месторасположение новой библиотеки шаблонов. (По умолчанию предлагается имя библиотеки, совпадающее с названием указанного шаблона (раздела) открытой библиотеки.) Затем нажмите кнопку Сохранить.

В окне Менеджера шаблонов откроется новая библиотека шаблонов, в которой будут содержаться только те элементы, которые существовали в исходном шаблоне (разделе).

Смотрите также:
_______________________________________________________

Создание библиотеки;
Открытие библиотеки;
Закрытие библиотеки;
Сохранение библиотеки;
Сохранение копии библиотеки;
Добавление новой библиотеки в существующую.


Ведение библиотеки шаблонов

Ведение библиотеки фрагментов предусматривает выполнение следующих действий:

· Создание:
- раздела библиотеки;
- шаблона;
- фрагмента двухмерного шаблона;
- детали трехмерного шаблона;
- таблицы параметров;
- заставки;

· Редактирование:
- атрибутов библиотеки;
- атрибутов раздела;
- шаблона;
- фрагмента (детали) шаблона;
- таблицы параметров шаблона;

· Удаление элементов библиотеки.


Создание раздела библиотеки

Команда Создать раздел предназначена для создания структурного элемента библиотеки, в котором могут располагаться другие разделы и шаблоны, объединенные каким-либо функциональным признаком.

1. Курсором укажите в дереве шаблонов элемент (библиотеку или ранее созданный раздел), в котором должен быть создан новый раздел.

2. Вызовите команду Создать раздел со страницы главного меню Правка или нажмите соответствующую кнопку на панели инструментов окна Менеджера шаблонов.
кнопка Создать раздел.

Откроется окно Создать раздел.

3. В поле Имя раздела введите название создаваемого раздела.

4. В поле Заставка укажите имя файла, который будет использоваться в качестве заставки к разделу. Для этого нажмите кнопку Открыть, расположенную справа от поля ввода.
кнопка Открыть.

В открывшемся стандартном диалоге Windows укажите имя файла (он должен обязательно находиться в директории, указанной при создании библиотеки), и нажмите кнопку Открыть. Заставка не является обязательным атрибутом раздела и может отсутствовать.

5. В окне Создать раздел нажмите кнопку ОК.

6. В окне Менеджера шаблонов введите комментарий – краткую информацию о созданном разделе.

Смотрите также:
_______________________________________________________

Редактирование раздела библиотеки;
Создание шаблона;
Создание фрагмента двухмерного шаблона;
Создание детали для трехмерного шаблона;
Создание таблицы параметров;
Создание заставки.


Создание шаблона

Команда Создать шаблон предназначена для создания нового элемента библиотеки – шаблона.

Под созданием шаблона понимается установка связей между документом КОМПАС-3D (фрагментом или деталью), EXCEL-таблицей параметров и схемой (фрагмент, деталь или файл с рисунком), содержащая имена параметров. Поэтому использовать команду Создать шаблон следует после того, как будут подготовлены все составляющие будущего шаблона.

Чтобы команда Создать шаблон была доступна, в дереве не должен быть выбран ни один шаблон.

1. Курсором укажите в дереве шаблонов элемент (библиотеку или раздел), в котором должен быть создан новый шаблон.

2. Вызовите команду Создать шаблон со страницы главного меню Правка или нажмите соответствующую кнопку на панели инструментов окна Менеджера шаблонов.
кнопка Создать шаблон.

Откроется окно Создать шаблон.

3. В поле Имя шаблона введите имя создаваемого шаблона.

4. В поля Файл КОМПАС-ГРАФИК, Таблица EXCEL и Заставка введите имена соответствующих составляющих шаблона. Пользуйтесь кнопкой Открыть, расположенной справа от каждого поля ввода, чтобы в стандартном диалоге Windows указать нужные файлы и подтвердить их использование.
кнопка Открыть.

5. В окне Создать шаблон нажмите кнопку ОК.

6. В окне Менеджера шаблонов введите комментарий – краткую информацию о созданном шаблоне.

Смотрите также:
_______________________________________________________

Редактирование шаблона;
Создание раздела библиотеки;
Создание фрагмента двухмерного шаблона;
Создание детали для трехмерного шаблона;
Создание таблицы параметров;
Создание заставки.


Создание фрагмента двухмерного шаблона

Фрагмент (файл формата *.frw) является составной частью двухмерного шаблона. Он создается в КОМПАС-3D обычными средствами.
При создании шаблона с параметризованной геометрией при построении фрагмента используются параметрические возможности чертежно-графического редактора КОМПАС-ГРАФИК. Изображение фрагмента шаблона можно будет увидеть в правой верхней части главного окна Менеджера шаблонов.

1. Создайте в КОМПАС-3D фрагмент.

2. Переменные, значения которых будут приниматься из таблицы параметров (файл EXCEL), назначьте внешними.

3. Если необходимо, в размерных надписях назначьте текстовые переменные (переменные для текстовых подстановок). Имя текстовой переменной должно быть заключено между двумя символами #.

4. Если вы планируете, что графические объекты фрагмента будут вставляться в документ КОМПАС-3D в различных комбинациях, поместите эти объекты в отдельные слои.

Например, если вы создаете шаблон пакета «Болт – Шайба – Гайка», целесообразно поместить каждый объект в отдельный слой, чтобы при вставке шаблона иметь возможность вставить и весь пакет, и только болт, и болт с гайкой, и т. д.

5. Каждому слою присвойте название. В название слоя могут входить:

· Переменная, обозначающая соответствующий объект (или группу объектов) фрагмента.

Значение переменной выбирается из таблицы EXCEL перед вставкой шаблона в документ КОМПАС-3D. Если оно будет равно нулю то слой, в названии которого есть эта переменная, будет удален при вставке фрагмента в документ КОМПАС-3D.

В название слоя могут входить несколько переменных. Если значение хотя бы одной из них будет равно нулю, то слой будет удален при вставке фрагмента в документ КОМПАС-3D.

· Служебное слово DELETING_LAYER, наличие которого означает, что графические объекты, принадлежащие этому слою, будут удалены при вставке в документ КОМПАС-3D. В слой с таким словом целесообразно помещать вспомогательные объекты.

· Служебное слово CLEAR _LAYER, наличие которого означает, что графические объекты, которые попадут в область, ограниченную графическими объектами этого слоя, будут удалены при вставке шаблона в документ КОМПАС-3D.

Имя переменной и служебное слово в названии слоя должны быть заключены между двумя символами #.

Например:

· Название слоя №2, на котором расположена деталь коричневого цвета, содержит имя переменной – det_s2. Если переменной det_s2 перед вставкой шаблона будет присвоено нулевое значение, эта деталь не будет отображена в документе КОМПАС-3D.

· Название слоя №3 -#DELETING_LAYER# – говорит о том, что объекты слоя (линейные размеры серого цвета) при вставке в документ КОМПАС-3D будут удалены.

· Название слоя №5 – #dim##det_s2# – содержит условие: при вставке шаблона в документ КОМПАС-3D размер dim (сиреневый цвет) будет отображен в том случае, если будет отображена деталь det_s2 (коричневый цвет).

· Условие в названии слоя №6 – #dim##det_s1##det_s2# – указывает на то, что при вставке шаблона размер dim будет отображен в том случае, если будут отображены и деталь det_s1, и деталь det_s2.

· Название слоя №7 – #CLEAR _LAYER# – означает, что при вставке шаблона в документ КОМПАС-3D части графических объектов, которые окажутся внутри области, ограниченной объектом слоя (розовой окружностью), будут удалены.

6. Вы можете задать базовые точки (точки за которые шаблон будет привязан к существующим объектам при вставке).

Для этого расставьте точки в нужные места и присвойте им атрибут «Базовая точка». Введите значения атрибутов (номера точек).

7. Сохраните файл с фрагментом.

Создание фрагментов проиллюстрировано в обучающей библиотеке demo.tlm, поставляемой с Менеджером шаблонов. Откройте эту библиотеку и ознакомьтесь с фрагментами шаблонов, расположенных в разделе 2D шаблоны.

Смотрите также:
_______________________________________________________

Редактирование фрагмента (детали) шаблона;
Создание раздела библиотеки;
Создание шаблона;
Создание детали для трехмерного шаблона;
Создание таблицы параметров;
Создание заставки.


Создание детали для трехмерного шаблона

Деталь (файл формата *.m3d) является составной частью трехмерного шаблона. Он создается в КОМПАС-3D обычными средствами.
При создании шаблона с параметризованной геометрией при построении фрагмента используются параметрические возможности КОМПАС-3D. Изображение детали шаблона можно будет увидеть в правой верхней части главного окна Менеджера шаблонов.

1. Создайте в КОМПАС-3D деталь.

2. Переменные, значения которых будут приниматься из таблицы параметров (файл EXCEL), назначьте внешними.

3. Сохраните файл с деталью.

Смотрите также:
_______________________________________________________

Редактирование фрагмента (детали) шаблона;
Создание раздела библиотеки;
Создание шаблона;
Создание фрагмента двухмерного шаблона;
Создание таблицы параметров;
Создание заставки.


Создание таблицы переменных

Таблица переменных (файл формата *.xls) является составной частью шаблона. Она создается в Microsoft EXCEL обычными средствами. Таблицу переменных шаблона можно будет увидеть в нижней части главного окна Менеджера шаблонов.

Одному EXCEL-файлу может быть поставлено в соответствие несколько фрагментов (деталей) КОМПАС-3D.

1. Создайте в Microsoft EXCEL книгу, в которой:

· первая строка – комментарий;

· вторая строка – имена переменных, назначенных во фрагменте (в детали);

Помните, что имена переменных чувствительны к регистру. Они должны быть полностью идентичны именам переменных во фрагменте (в детали).

· третья строка – пояснение к переменным (необязательная строка);

· четвертая строка:
- «True» – под переменными, значение которых всегда выводится в таблице переменных;
- «Condition» – под переменными, значение которых выводится в таблице переменных при наличии таких переменных во фрагменте;
- «False» – под переменными, значение которых никогда не выводится в таблице переменных.

· пятая строка – тип переменных:
- «Const» – переменные имеют постоянные значения;
- «Integer» – значения переменных – целые числа;
- «Float» – значения переменных – действительные числа;
- «Bool» – логические переменные (0 или 1);

· шестая строка – интервал значений, которые может принимать переменная:
- «MinMaxRange» – значение переменной выбирается из указанного интервала значений; варианты интервалов:
От {min} до {max};
Св. {min} до {max};
{min} <(или <=) {переменная} <(или <=) {мах};
{min} ~ {max};
- «MinRange» – значение переменной превышает указанное значение или равно ему; варианты:
От {min};
Св. {min};
>(или>=) {min};
- «MaxRange» – значение переменной не превышает указанное значение или равно ему; варианты:
До {max};
<(или <=) {max};
- «DropDownList» – значение переменной выбирается из раскрывающегося списка;
для каждого значения переменной может быть сформирован свой список, в котором одно из списочных значений может быть объявлено значением по умолчанию.

В фигурных скобках приводятся числа или переменные.

· последующие строки – значения переменных.

2. Сохраните файл с таблицей.

Примеры к разделу «Создание таблицы параметров»:

Создание таблиц параметров проиллюстрировано в обучающей библиотеке demo.tlm, поставляемой с Менеджером шаблонов. Откройте эту библиотеку и ознакомьтесь с EXCEL-таблицами шаблонов, расположенных во всех разделах.

Смотрите также:
_______________________________________________________

Редактирование таблицы параметров;
Создание раздела библиотеки;
Создание шаблона;
Создание фрагмента двухмерного шаблона;
Создание детали для трехмерного шаблона;
Создание заставки.


Создание схемы параметров (заставки)

Схема параметров (фрагмент, деталь или файл с рисунком) является составной частью шаблона. Она содержит изображение конструктивного элемента и имена переменных (размеров и базовых точек), которые нужно выбирать из таблицы EXCEL.

Заставка – графическое изображение, иллюстрирующее название библиотеки шаблонов или ее раздела.

Схему параметров шаблона (заставку) можно будет увидеть в правой верхней части главного окна Менеджера шаблонов.

Схема параметров и заставка создаются в КОМПАС-3D или в любом графическом редакторе.

1. Создайте изображение конструктивного элемента и укажите его переменные параметры. Это может быть файл КОМПАС-3D (формата *.frw, *.cdw, *.m3d, *.a3d) или файл рисунков (формата *.bmp, *.gif, *.jpg, *.jpeg).

2. Сохраните файл.

Смотрите также:
_______________________________________________________

Создание раздела библиотеки;
Создание шаблона;
Создание фрагмента двухмерного шаблона;
Создание детали для трехмерного шаблона;
Создание таблицы параметров.


Редактирование атрибутов раздела библиотеки

Команда Редактировать элемент библиотеки поможет вам изменить атрибуты раздела библиотеки – переименовать раздел, выбрать другой файл с заставкой.

Чтобы команда Редактировать элемент библиотеки была доступна, в дереве не должен быть выбран ни один шаблон.

1. Курсором укажите название раздела библиотеки в дереве шаблонов.

2. Вызовите команду Редактировать элемент библиотеки со страницы главного меню Правка, из контекстного меню или нажмите соответствующую кнопку на панели инструментов окна Менеджера шаблонов.
кнопка Редактировать элемент библиотеки.

Откроется окно Редактировать раздел.

3. Чтобы переименовать раздел, в поле Имя раздела введите новое название.

4. Чтобы заменить файл заставки к разделу, в поле Заставка нажмите кнопку Открыть, и в открывшемся стандартном диалоге Windows укажите имя другого файла с заставкой (файл должен обязательно находиться в директории, указанной при создании библиотеки), а затем нажмите кнопку OK.
кнопка Открыть.

Заставка не является обязательным атрибутом раздела и может отсутствовать.

5. В окне Редактировать раздел нажмите кнопку ОК.

6. При необходимости в окне Менеджера шаблонов измените краткую информацию о разделе библиотеки – отредактируйте комментарий.


Редактирование шаблона

Команда Редактировать элемент библиотеки поможет вам изменить шаблон библиотеки – переименовать его, выбрать другие файл КОМПАС-КОМПАС-3D (фрагмент или деталь), файл Microsoft EXCEL (таблица переменных), файл с заставкой (схема параметров шаблона).

Чтобы команда Редактировать элемент библиотеки была доступна, в дереве не должен быть выбран ни один шаблон.

1. Курсором укажите шаблон в дереве.

2. Вызовите команду Редактировать элемент библиотеки со страницы главного меню Правка, из контекстного меню или нажмите соответствующую кнопку на панели инструментов окна Менеджера шаблонов.
кнопка Редактировать элемент библиотеки.

Откроется окно Редактировать шаблон.

3. Чтобы переименовать шаблон, в поле Имя шаблона введите новое название.

4. В поля Файл КОМПАС-ГРАФИК, Таблица EXCEL и Заставка введите другие имена составляющих шаблона. Пользуйтесь кнопкой Открыть, расположенной справа от каждого поля ввода, чтобы в стандартном диалоге Windows указать нужные файлы и подтвердить их использование.
кнопка Открыть.

5. В окне Редактировать шаблон нажмите кнопку ОК.

6. При необходимости в окне Менеджера шаблонов измените краткую информацию о шаблоне – отредактируйте комментарий.


Редактирование фрагмента (детали) шаблона

Команда Редактировать файл КОМПАС-3D поможет вам изменить содержимое фрагмента (детали) шаблона, не прекращая сеанс работы с Менеджером шаблонов.

При вызове команды Редактировать файл КОМПАС-3D будет открыт для изменения тот объект КОМПАС-3D (фрагмент шаблона, модель или заставка), который в данный момент отображен в главном окне Менеджера шаблонов.

Чтобы поменять объект редактирования, дважды щелкните мышью в по изображению.

1. Выберите объект для редактирования.

2. Вызовите команду Редактировать файл КОМПАС-3D со страницы главного меню Правка, из контекстного меню или нажмите соответствующую кнопку на панели инструментов окна Менеджера шаблонов.
кнопка Редактировать файл КОМПАС-3D.

Откроется документ (фрагмент или деталь) КОМПАС-3D.

3. Измените необходимые параметры объекта.

4. Сохраните изменения и закройте документ КОМПАС-3D.

В главном окне Менеджера шаблонов отобразится отредактированный объект.

5. Сохраните изменения в библиотеке шаблонов – вызовите команду Сохранить со страницы главного меню Библиотека или нажмите соответствующую кнопку на панели инструментов окна Менеджера шаблонов.
кнопка Сохранить.


Редактирование таблицы переменных

Команда Редактировать таблицу EXCEL поможет вам изменить содержимое таблицы переменных шаблона, не прекращая сеанс работы с Менеджером шаблонов.

При вызове команды Редактировать таблицу EXCEL будет открыт для изменения файл Microsoft EXCEL, связанный с шаблоном, изображение которого вы видите в данный момент в главном окне Менеджера шаблонов.

1. Укажите в дереве шаблон, у которого нужно отредактировать таблицу переменных.

2. Вызовите команду Редактировать таблицу EXCEL со страницы главного меню Правка, из контекстного меню или нажмите соответствующую кнопку на панели инструментов окна Менеджера шаблонов.
кнопка Редактировать таблицу EXCEL.

Откроется документ Microsoft EXCEL с таблицей параметров указанного шаблона.

3. Отредактируйте таблицу параметров.

4. Сохраните изменения и закройте документ Microsoft EXCEL.

5. Сохраните изменения в библиотеке шаблонов – вызовите команду Сохранить со страницы главного меню Библиотека или нажмите соответствующую кнопку на панели инструментов окна Менеджера шаблонов.
кнопка Сохранить.


Удаление элемента библиотеки

Команда Удалить элемент библиотеки поможет вам убрать из библиотеки ненужные разделы и шаблоны.

Чтобы команда Удалить элемент библиотеки была доступна, в дереве не должен быть выбран ни один шаблон.

1. Курсором укажите в дереве шаблонов раздел или шаблон, который нужно удалить.

2. Вызовите команду Удалить элемент библиотеки со страницы главного меню Правка, из контекстного меню или нажмите соответствующую кнопку на панели инструментов окна Менеджера шаблонов.
кнопка Удалить элемент библиотеки.

Откроется окно, в котором нужно подтвердить удаление элемента.

3. Чтобы удалить элемент, нажмите кнопку Да, чтобы отказаться от удаления – кнопку Нет.


Выбор шаблона

В главном окне Менеджера шаблонов таблица переменных отображается только для того шаблона, который выбран в дереве шаблонов.

Команда Выбрать шаблон предназначена для указания шаблона, для которого следует отображать таблицу переменных.

Команда Выбрать шаблон доступна только в том случае, если в библиотеке нет несохраненных элементов (т.е. только при сохраненной библиотеке).

Чтобы выбрать шаблон, выполните следующие действия.

1. Если в библиотеке шаблонов в данный момент присутствуют несохраненные элементы, сохраните изменения – вызовите со страницы главного меню Библиотека команду Сохранить или нажмите соответствующую кнопку на панели инструментов окна Менеджера шаблонов.
кнопка Сохранить.

2. В дереве шаблонов щелчком мыши укажите шаблон. Он будет выделен цветом.
– значок невыбранного шаблона.

3. Выполните одно из действий:
· вызовите со страницы главного меню Правка команду Выбрать шаблон;
· нажмите на панели инструментов окна Менеджера шаблонов кнопку Выбрать шаблон
кнопка Выбрать шаблон;
· нажмите клавишу <Enter>;
· дважды щелкните мышью по значку шаблона.

Значок шаблона изменится, в главном окне отобразится таблица переменных выбранного шаблона и появится панель инструментов таблицы переменных.
– значок выбранного шаблона.

Чтобы отменить выбор шаблона, укажите его курсором и выполните одно из действий, перечисленных в п.3.


Присвоение значений переменным параметрам шаблона

Перед тем как вставлять выбранный шаблон из библиотеки в документ КОМПАС-3D, необходимо присвоить значения переменным, приведенным в таблице переменных.

Чтобы присвоить значения переменным параметрам шаблона, выполните следующие действия.

1. В таблице переменных выберите строку, подходящую по диапазону значений.

2. Введите значение каждой переменной, приведенной в таблице. Для этого щелкните мышью в ячейке, соответствующей переменной.

Если справа от поля ввода значения появится кнопка с черным треугольником, нажмите ее и выберите значение из раскрывшегося списка.

Если появятся две кнопки с треугольниками (вершины треугольников направлены в противоположные стороны), выберите значение параметра, воспользовавшись кнопками, либо введите его при помощи клавиатуры.

Для подтверждения ввода значения переменной нажмите клавишу <Enter>.

3. Щелчком мыши снимите «галочки» в ячейках тех объектов шаблона, которые не должны быть вставлены в документ КОМПАС-3D, или поставьте «галочки» в ячейках тех объектов шаблона, которые должны быть вставлены в документ КОМПАС-3D.

4. Для двухмерного шаблона выберите базовую точку – точку, за которую будет «привязан» фрагмент при вставке. Для этого щелкните мышью в ячейке «б.т.». Справа от поля ввода появится кнопка с черным треугольником. Нажмите ее и выберите базовую точку из раскрывшегося списка. Расположение базовых точек, как правило, указано на схеме параметров шаблона.

5. Чтобы восстановить первоначальные значения переменных, нажмите на панели инструментов таблицы переменных кнопку Восстановить исходные значения.
кнопка Восстановить исходные значения.

6. Когда все необходимые параметры будут определены, строка таблицы будет выделена цветом (при стандартной цветовой схеме Windows – зелёным), и активизируется панель инструментов таблицы переменных. Вы сможете вставить шаблон с указанными в таблице значениями параметров в документ КОМПАС-3D.

Смотрите также:
_______________________________________________________

Вставка двухмерного шаблона;
Вставка трехмерного шаблона.


Вставка двухмерного шаблона

Вставка двухмерного шаблона в документ КОМПАС-3D

После того, как всем переменным параметрам выбранного шаблона присвоены значения, можно вставлять шаблон в документ КОМПАС-3D.

Двухмерный шаблон можно вставить разными способами:

1. Не объединять вставляемый фрагмент в макроэлемент. Для этого нужно нажать на панели инструментов таблицы переменных кнопку Вставить фрагмент россыпью.
кнопка Вставить фрагмент россыпью.

2. Объединить вставляемый фрагмент в нередактируемый макроэлемент. Для этого нужно нажать на панели инструментов таблицы переменных кнопку Вставить нередактируемый макроэлемент.
кнопка Вставить нередактируемый макроэлемент.

3. Объединить вставляемый фрагмент в редактируемый макроэлемент. Для этого нужно нажать панели инструментов таблицы переменных кнопку Вставить редактируемый макроэлемент.
кнопка Вставить редактируемый макроэлемент.

4. Если необходимо вставить один и тот же фрагмент несколько раз подряд, перед вставкой нажмите кнопку Непрерывный ввод объектов.
кнопка Непрерывный ввод объектов.

Панель инструментов таблицы переменных появляется только при одновременном выполнении двух условий:
· в дереве шаблонов выбран шаблон;
· в КОМПАС-3D открыт документ, соответствующий типу шаблона (для двухмерного шаблона – фрагмент или чертеж, для трехмерного шаблона – деталь или сборка).

5. После того, как вы нажмете одну из кнопок вставки объекта, в активном документе КОМПАС-3D появится фантом вставляемого фрагмента. Одновременно откроется окно, в котором будут перечислены возможные варианты изменения ориентации фрагмента при вставке относительно исходного положения.

При необходимости двойным щелчком мыши выберите одну из строк.

СТРОКА

ДЕЙСТВИЕ С ФРАГМЕНТОМ

Следующая базовая точка

Привязка фрагмента будет осуществлена за следующую по номеру базовую точку.

Включить угол

После указания места привязки в поле документа КОМПАС-3D будет возможность задать угол, на который нужно повернуть вставляемый фрагмент.

Отключить угол

Отказаться от возможности задать угол поворота вставляемого фрагмента. При этом фрагмент будет вставляться с тем углом поворота, который был у фантома на момент выбора строки Отключить угол.

Симметрия относительно оси X

Вставляемый фрагмент будет отражен относительно оси X

Симметрия относительно оси Y

Вставляемый фрагмент будет отражен относительно оси Y

Исходное положение

Вставляемый фрагмент будет отражен в исходном положении

6. Щелкните мышью в той точке поля документа КОМПАС-3D, где должна находиться точка привязки вставляемого фрагмента.

Смотрите также:
_______________________________________________________

Присвоение значений переменным параметрам шаблона
Вставка трехмерного шаблона;
Редактирование двухмерного шаблона.


Вставка трехмерного шаблона

Вставка трехмерного шаблона в документ КОМПАС-3D

После того, как всем переменным параметрам шаблона присвоены значения, можно вставлять шаблон в документ КОМПАС-3D. Вставить трехмерный шаблон можно разными способами:

· в сборку, как редактируемую деталь, со ссылкой на источник;
· в сборку, как редактируемую деталь, без ссылки на источник;
· в сборку, как нередактируемую деталь, со ссылкой на источник;
· в сборку, как нередактируемую деталь, без ссылки на источник;
· как редактируемый библиотечный элемент.

Смотрите также:
_______________________________________________________

Присвоение значений переменным параметрам шаблона
Вставка двухмерного шаблона.


Редактируемая деталь со ссылкой на источник

После того, как всем переменным параметрам выбранного шаблона присвоены значения, можно вставлять шаблон в документ КОМПАС-3D.

Чтобы вставить трехмерный шаблон в сборку КОМПАС-3D в качестве редактируемой детали, при этом сохранить деталь в файле-источнике формата *.m3d и сохранить ссылку на файл-источник, выполните следующие действия:

1. Откройте в КОМПАС-3D документ типа КОМПАС-Сборка.

2. В окне Менеджера шаблонов нажмите на панели инструментов таблицы переменных кнопку Вставить деталь в сборку со ссылкой на источник.
кнопка Вставить деталь в сборку со ссылкой на источник.

3. Если документ типа КОМПАС-Сборка еще не имеет названия, откроется окно, в котором необходимо будет дать файлу имя, указать его месторасположение (или указать уже существующий файл, куда нужно вставить деталь) и нажать кнопку Сохранить.

4. Щелчком мыши укажите в поле документа место, куда нужно поместить деталь, и нажмите кнопку Создать объект на панели инструментов КОМПАС-3D.
кнопка Создать объект.

Деталь будет вставлена в сборку КОМПАС-3D. Файл-источник будет размещен в той же директории, что и файл сборки.

Деталь, вставленную таким способом, можно отредактировать средствами КОМПАС-3D в файле сборки или в файле-источнике. При изменении параметров детали в одном из файлов произойдет изменение соответствующих параметров и в другом файле.

Смотрите также:
_______________________________________________________

Редактирование детали, вставленной в сборку со ссылкой на источник.


Редактируемая деталь без ссылки на источник

После того, как всем переменным параметрам выбранного шаблона присвоены значения, можно вставлять шаблон в документ КОМПАС-3D.

Чтобы вставить трехмерный шаблон в сборку КОМПАС-3D в качестве редактируемой детали и при этом не сохранять деталь в файле-источнике формата *.m3d, выполните следующие действия:

1. Откройте в КОМПАС-3D документ типа КОМПАС-Сборка.

2. В окне Менеджера шаблонов нажмите на панели инструментов таблицы переменных кнопку Вставить деталь в сборку «телом», без сохранения ссылки на источник.
кнопка Вставить деталь в сборку «телом», без сохранения ссылки на источник.

3. Если документ типа КОМПАС-Сборка еще не имеет названия, откроется окно, в котором необходимо будет дать файлу имя, указать его месторасположение (или указать уже существующий файл, куда нужно вставить деталь) и нажать кнопку Сохранить.

4. Щелчком мыши укажите в поле документа место, куда нужно поместить деталь и нажмите кнопку Создать объект на панели инструментов КОМПАС-3D.
кнопка Создать объект.

Деталь будет вставлена в сборку КОМПАС-3D.

Деталь, вставленную таким способом, можно отредактировать средствами КОМПАС-3D только в файле сборки.

Смотрите также:
_______________________________________________________

Редактирование детали, вставленной в сборку без сохранения ссылки на источник.


Нередактируемая деталь со ссылкой на источник

После того, как всем переменным параметрам выбранного шаблона присвоены значения, можно вставлять шаблон в документ КОМПАС-3D.

Чтобы вставить трехмерный шаблон в сборку КОМПАС-3D в качестве нередактируемой детали, при этом сохранить деталь в файле-источнике формата *.m3d и сохранить ссылку на файл-источник, выполните следующие действия:

1. Откройте в КОМПАС-3D документ типа КОМПАС-Сборка.

2. В окне Менеджера шаблонов нажмите на панели инструментов таблицы переменных кнопку Вставить нередактируемую деталь в сборку со ссылкой на источник.
кнопка Вставить нередактируемую деталь в сборку со ссылкой на источник.

3. Если документ типа КОМПАС-Сборка еще не имеет названия, откроется окно, в котором необходимо будет дать файлу имя, указать его месторасположение (или указать уже существующий файл, куда нужно вставить деталь) и нажать кнопку Сохранить.

4. Щелчком мыши укажите в поле документа место, куда нужно поместить деталь и нажмите кнопку Создать объект на панели инструментов КОМПАС-3D.
кнопка Создать объект.

Деталь будет вставлена в сборку КОМПАС-3D. Файл-источник будет размещен в той же директории, что и файл сборки.

Деталь, вставленную таким способом, можно отредактировать средствами КОМПАС-3D только в файле-источнике. При изменении параметров детали в файле-источнике произойдет изменение соответствующих параметров детали в сборке.

Смотрите также:
_______________________________________________________

Изменение параметров нередактируемой детали, вставленной в сборку без сохранения ссылки на источник.


Нередактируемая деталь без ссылки на источник

После того, как всем переменным параметрам выбранного шаблона присвоены значения, можно вставлять шаблон в документ КОМПАС-3D.

Чтобы вставить трехмерный шаблон в сборку КОМПАС-3D в качестве нередактируемой детали и при этом не сохранять деталь в файле-источнике формата *.m3d, выполните следующие действия:

1. Откройте в КОМПАС-3D документ типа КОМПАС-Сборка.

2. В окне Менеджера шаблонов нажмите на панели инструментов таблицы переменных кнопку Вставить нередактируемую деталь в сборку «телом», без сохранения ссылки на источник.
кнопка Вставить нередактируемую деталь в сборку «телом», без сохранения ссылки на источник.

3. Если документ типа КОМПАС-Сборка еще не имеет названия, откроется окно, в котором необходимо будет дать файлу имя, указать его месторасположение (или указать уже существующий файл, куда нужно вставить деталь) и нажать кнопку Сохранить.

4. Щелчком мыши укажите в поле документа место, куда нужно поместить деталь и нажмите кнопку Создать объект на панели инструментов КОМПАС-3D.
кнопка Создать объект.

Деталь будет вставлена в сборку КОМПАС-3D.

Деталь, вставленную таким способом, отредактировать невозможно.


Редактируемый библиотечный элемент

После того, как всем переменным параметрам выбранного шаблона присвоены значения, можно вставлять шаблон в документ КОМПАС-3D.

Чтобы вставить трехмерный шаблон в сборку КОМПАС-3D в качестве редактируемого библиотечного элемента, выполните следующие действия:

1. Откройте в КОМПАС-3D документ типа КОМПАС-Сборка.

2. В окне Менеджера шаблонов нажмите на панели инструментов таблицы переменных кнопку Вставить редактируемый библиотечный элемент.
кнопка Вставить редактируемый библиотечный элемент.

3. Если документ типа КОМПАС-Сборка еще не имеет названия, откроется окно, в котором необходимо будет дать файлу имя, указать его месторасположение (или указать уже существующий файл, куда нужно вставить деталь) и нажать кнопку Сохранить.

4. Щелчком мыши укажите в поле документа место, куда нужно поместить деталь и нажмите кнопку Создать объект на панели инструментов КОМПАС-3D.
кнопка Создать объект.

Деталь будет вставлена в сборку КОМПАС-3D как библиотечный элемент.

Деталь, вставленную таким способом, можно редактировать как библиотечный элемент КОМПАС-3D.

Смотрите также:
_______________________________________________________

Редактирование детали, вставленной в качестве библиотечного элемента.


Создание детали на основе шаблона

После того, как всем переменным параметрам выбранного шаблона присвоены значения, можно вставлять шаблон в документ КОМПАС-3D.

Чтобы создать деталь на основе выбранного шаблона, выполните следующие действия:

1. Откройте в КОМПАС-3D документ типа сборка КОМПАС-Деталь.

2. В окне Менеджера шаблонов нажмите на панели инструментов таблицы переменных кнопку Создать деталь.
кнопка Создать деталь.

3. В открывшемся окне укажите имя для записи файла КОМПАС-Деталь и его месторасположение. Нажмите кнопку Сохранить.

Деталь, созданную на основе шаблона, можно редактировать средствами КОМПАС-3D.


Редактирование двухмерного шаблона

Отредактировать двухмерный шаблон, вставленный в документ КОМПАС-3D, можно только если он вставлен как редактируемый макроэлемент.

Чтобы изменить параметры вставленного в документ КОМПАС-3D двухмерного шаблона, выполните следующие действия:

1. Дважды щелкните мышью на вставленном шаблоне в документе КОМПАС-3D.

Откроется окно Менеджера шаблонов.

2. Измените значения параметров в таблице переменных.

На панели инструментов таблицы переменных активизируется кнопка Указать новое положение при вставке.
кнопка Указать новое положение при вставке.

Если вы хотите оставить отредактированный шаблон на прежнем месте в поле документа КОМПАС-3D, отожмите кнопку Указать новое положение при вставке.

3. Вставьте отредактированный двухмерный шаблон в документ КОМПАС-3D.


Деталь, вставленная со ссылкой на источник

Чтобы изменить редактируемую деталь, вставленную в сборку со ссылкой на источник (при помощи команды Вставить деталь в сборку со ссылкой на источник), выполните следующие действия:

1. Откройте в КОМПАС-3D документ типа КОМПАС-Сборка, в который со ссылкой на источник была вставлена деталь из библиотеки шаблонов.

2. Укажите эту деталь в Дереве построения и щелчком правой клавиши мыши вызовите контекстное меню.

3. В контекстном меню выберите:
· команду Редактировать на месте, чтобы изменить параметры вставленной детали непосредственно в файле сборки;
· команду Редактировать в окне, чтобы изменить параметры вставленной детали в файле-источнике.

4. Отредактируйте деталь средствами КОМПАС-3D и сохраните файл.

Изменения параметров детали в одном из файлов (в файле сборки или в файле-источнике) приведут к изменениям этих параметров в другом файле.


Деталь, вставленная без ссылки на источник

Чтобы изменить редактируемую деталь, вставленную в сборку без ссылки на источник (при помощи команды Вставить деталь в сборку «телом», без сохранения ссылок на источник), выполните следующие действия:

1. Откройте в КОМПАС-3D документ типа КОМПАС-Сборка, в который без ссылки на источник была вставлена деталь из библиотеки шаблонов.

2. Укажите эту деталь в Дереве построения и щелчком правой клавиши мыши вызовите контекстное меню.

3. В контекстном меню выберите команду Редактировать на месте, чтобы изменить параметры вставленной детали в файле сборки.

4. Отредактируйте деталь средствами КОМПАС-3D и сохраните файл.


Нередактируемая деталь, вставленной со ссылкой на источник

Чтобы изменить нередактируемую деталь, вставленную в сборку со ссылкой на источник (при помощи команды Вставить нередактируемую деталь в сборку со ссылкой на источник), выполните следующие действия:

1. Откройте файл-источник детали.

2. Отредактируйте деталь средствами КОМПАС-3D.

3. Сохраните и закройте файл-источник.

Изменения параметров детали в файле-источнике приведут к изменению этих параметров детали и в файле сборки.


Деталь, вставленная как библиотечный элемент

Чтобы изменить нередактируемую деталь, вставленную в сборку как редактируемый библиотечный элемент (при помощи команды Вставить редактируемый библиотечный элемент), выполните следующие действия:

1. Откройте в КОМПАС-3D документ типа КОМПАС-Сборка, в который была вставлена деталь из библиотеки шаблонов.

2. Укажите эту деталь в Дереве построения и щелчком правой клавиши мыши вызовите контекстное меню.

3. В контекстном меню выберите команду Редактировать.

Откроется главное окно Менеджера шаблонов.

4. Измените значения параметров шаблона в таблице переменных.

На панели инструментов таблицы переменных активизируется кнопка Указать новое положение при вставке.
кнопка Указать новое положение при вставке.

Если вы хотите оставить отредактированный шаблон на прежнем месте в поле документа КОМПАС-3D, отожмите кнопку Указать новое положение при вставке.

5. Вставьте отредактированный трехмерный шаблон в документ КОМПАС-3D.


Поиск элементов библиотеки

Команда Найти предназначена для поиска элементов библиотеки в дереве шаблонов.

1. Вызовите команду Найти со страницы главного меню Поиск или нажмите клавиши <Ctrl>+<F>.

Откроется окно Поиск.

2. В строке Найти введите символы, которые должны содержатся в искомом элементе.

3. Установите направление поиска – вверх, вниз или от начала до конца. Для этого включите одну из кнопок в группе Направление поиска.

4. Определите режим поиска, щелчком мыши установив (сняв) флажки в группе Режим показа.

5. Отметьте названия столбцов, в которых необходимо искать элементы, содержащие введенные для поиска символы. Для этого щелчком мыши установите (снимите) флажки в группе Искать в столбцах.

6. Для начала поиска нажмите кнопку ОК.

В результате поиска будет выделен первый элемент, в котором содержатся введенные для поиска символы. Для поиска следующего элемента нажмите клавиши <Shift>+<F3>.

Если элементы не будут найдены, появится соответствующее информационное сообщение.


Замена элементов библиотеки

Команда Заменить предназначена для поиска элементов библиотеки в дереве шаблонов и замены их названий путем изменения поисковых символов на символы, введенные в окне команды.

1. Вызовите команду Заменить со страницы главного меню Поиск или нажмите клавиши <Ctrl>+<R>.

Откроется окно Заменить.

2. В строке Найти введите символы, которые должны содержатся в искомом элементе.

3. В строке Заменить на введите символы, на которые должны быть заменены поисковые символы в названии найденного элемента.

4. Установите направление поиска – вверх, вниз или от начала до конца. Для этого включите одну из кнопок в группе Направление поиска.

5 Определите режим поиска, щелчком мыши установив (сняв) флажки в группе Режим показа.

6. Отметьте названия столбцов, в которых необходимо искать элементы, содержащие введенные для поиска символы. Для этого щелчком мыши установите (снимите) флажки в группе Искать в столбцах.

7. Для начала поиска нажмите кнопку ОК.

В результате работы команды будет выделен первый элемент, в котором содержатся введенные для поиска символы, и откроется окно с предложением замены.

В открывшемся окне Замена:

· нажмите кнопку Да, если хотите заменить выделенный элемент;
· нажмите кнопку Нет, если не следует производить замену выделенного элемента, а нужно перейти к следующему элементу, удовлетворяющему условиям поиска;
· нажмите кнопку Отмена, если хотите отказаться от замены элементов;
· нажмите кнопку Заменить все, если хотите заменить все элементы, которые будут найдены в результате поиска.

Если искомые элементы в библиотеке отсутствуют, появится соответствующее информационное сообщение.


Выбранный шаблон

 Выбранный шаблон – шаблон, для которого отображается таблица переменных. Выбранный шаблон нельзя редактировать и удалять.
Он отмечается в дереве шаблонов специальным значком.
– выбранный шаблон.
– невыбранный шаблон.

Для того чтобы изменить активность шаблона, дважды щелкните мышью по его пиктограмме или воспользуйтесь командой Выбрать шаблон.


 Копировать

Чтобы скопировать раздел или шаблон в буфер обмена Менеджера шаблонов, курсором укажите этот элемент в дереве шаблонов и вызовите из контекстного меню команду Копировать.

Копия объекта будет сохраняться в буфере обмена до тех пор, пока вы не воспользуетесь командой Вырезать или Копировать либо не завершите сеанс работы с Менеджером шаблонов.


 Вырезать

Чтобы удалить раздел или шаблон из дерева шаблонов и поместить его в буфер обмена Менеджера шаблонов, курсором укажите этот элемент в дереве шаблонов и вызовите из контекстного меню команду Вырезать. Пиктограмма элемента станет серого цвета. При переоткрытии раздела она исчезнет.

Объект будет сохраняться в буфере обмена до тех пор, пока вы не воспользуетесь командой Вырезать или Копировать либо не завершите сеанс работы с Менеджером шаблонов.


 Вставить

Чтобы вставить в дерево шаблонов копию раздела или шаблона, ранее помещенного в буфер обмена Менеджера шаблонов, курсором укажите в дереве шаблонов тот элемент, перед которым должна быть вставлена копия, и вызовите из контекстного меню команду Вставить.

Команда будет доступна только в том случае, если буфер обмена Менеджера шаблонов не пуст.


Горячие клавиши

 Горячие клавиши – клавиша или сочетание клавиш, посредством которых можно оперативно вызвать ту или иную команду, не прибегая к помощи меню.


Комментарий

 Комментарий может содержать краткое описание шаблона, раздела, библиотеки.


Заголовок окна

 Заголовок главного программного окна содержит название самой библиотеки – Менеджер шаблонов – и название открытой библиотеки шаблонов.


Панель переменных

 Панель инструментов таблицы переменных содержит кнопки вызова команд, которые предназначены:

· для восстановления исходных значений переменных;
· для выбора способа вставки шаблона в документ КОМПАС-3D.

Панель инструментов таблицы переменных появляется только тогда, когда в дереве шаблонов выбран определеннывй шаблон, и в окне КОМПАС-3D открыт соответствующий типу шаблона документ.

Набор кнопок на панели для двухмерных шаблонов отличается от панели инструментов для трехмерных шаблонов.


2-х мерный шаблон

 Кнопки панели инструментов для двухмерного шаблона:

Восстановить исходные значения;
Указать новое положение при вставке;
Непрерывный ввод объектов;
Вставить фрагмент россыпью;
Вставить нередактируемый макроэлемент;
Вставить редактируемый макроэлемент.


3-х мерный шаблон

 Кнопки панели инструментов для трехмерного шаблона:

Восстановить исходные значения;
Создать деталь;
Вставить деталь в сборку со ссылкой на источник;
Вставить деталь в сборку «телом» без сохранения ссылки на источник;
Вставить нередактируемую деталь в сборку со ссылкой на источник;
Вставить нередактируемую деталь в сборку «телом» без сохранения ссылки на источник;
Вставить редактируемый библиотечный элемент.


Изображение шаблона

 Изображение шаблона – окно, которое может содержать изображение файла КОМПАС-3D, в котором хранитcя фрагмент (деталь) шаблона, либо файла, в котором хранится схема параметров шаблона или заставка библиотеки.

Чтобы переключиться с одного изображения на другое, дважды щелкните мышью по изображению или щелкните мышью по изображению и нажмите клавишу <F6>.


Строка состояния

 Строка состояния содержит в левой части полное имя выделенного элемента библиотеки, в правой – полное имя выбранного шаблона. Дважды щелкните мышью по строке состояния, чтобы перейти в дереве к выбранному шаблону.


Разделительная линейка

 Разделительная линейка позволяет скрывать (раскрывать) области, на которые указывают вершины треугольников, расположенных на линейке.

Если нажать на линейку, область будет скрыта. Повторный щелчок мыши по линейки приведет к возвращению видимости области.


Таблица переменных

 Таблица переменных содержит список возможных значений параметров выбранного шаблона. Этот список определяется при создании файла Microsoft EXCEL, связанного с выбранным шаблоном.

Таблица параметров имеет свою инструментальную панель.


Дерево шаблонов

 Дерево шаблонов – средство для навигации по библиотеке и получения информации о шаблонах.

Управление элементами дерева осуществляется при помощи команд контекстного меню дерева, кнопок панели инструментов и команд главного меню Менеджера шаблонов.


Элементы библиотеки

Библиотека шаблонов может состоять из следующих элементов:


Макроэлемент

 Макроэлемент – это объект, состоящий из нескольких простых
объектов. Макроэлемент воспринимается системой (выделяется,
перемещается, удаляется) как единое целое. Ни один из входящих
в макроэлемент простых объектов нельзя редактировать или
удалять отдельно, а если такие действия необходимы, то сначала
нужно разрушить макроэлемент.


Шаблон

 Шаблон – это элемент библиотеки, созданной с помощью Менеджера шаблонов. Он представляет собой совокупность трех составляющих: документ КОМПАС-3D (фрагмент или деталь), сопоставленная ему EXCEL-таблица переменных и схема (фрагмент, деталь или файл с рисунком), содержащая имена переменных (параметров).
Шаблоны могут быть двухмерными (фрагмент) и трехмерными (деталь). Двухмерный шаблон состоит из одного слоя.

Примеры шаблонов: сварные швы, крепежные изделия, профили и т. д.


Библиотека шаблонов

 Библиотека шаблонов – это совокупность следующих взаимосвязанных составляющих:

· фрагмент (деталь), созданный в КОМПАС-3D – файл формата *.frw (*.m3d);
· таблица параметров, созданная в Microsoft EXCEL – файл формата *.xls;
· схема (фрагмент, деталь или файл с рисунком);
· собственно библиотека – файл формата *.tlm.


Правка

Страница меню Правка содержит команды управления элементами выбранной библиотеки:


Справка

 Страница Справка содержит команды Вызов справки и О программе. Команда Вызов справки поможет вам войти в основную систему помощи библиотеки Менеджер шаблонов. Команда О программе позволит получить информацию о номере сборки библиотеки и электронном адресе службы технической поддержки.


Библиотека

Страница меню Библиотека содержит команды управления библиотеками, а также команду Выход, предназначенную для завершения работы Менеджера шаблонов.


Вид

 Страница меню Вид содержит команды, с помощью которых можно управлять отображением дополнительной информации о шаблонах (библиотеке) в дереве шаблонов.

Выбрав одну из команд, вы дадите указание показать (скрыть) в дереве шаблонов столбец со значениями одного из параметров:

Кнопка

Команда

Отображаемый параметр

«Горячие» клавиши

Директория
(для библиотеки)

имя директории, в которой хранитcя библиотека шаблонов

<F2>

Столбец «Файл КОМПАС-3D»
(для шаблона)

имя файла КОМПАС-3D, в котором хранитcя фрагмент (деталь) шаблона

<F2>

Столбец «Таблица EXCEL»

имя файла Microsoft EXCEL, в котором хранится таблица параметров шаблона

<F3>

Столбец «Заставка»

название файла, в котором хранится схема параметров шаблона или заставка библиотеки

<F4>

Показать все столбцы

все столбцы с дополнительными параметрами

<F5>

Скрыть все столбцы

все столбцы с дополнительными параметрами скрыты

<Ctrl>+<F5>

Повторный выбор команды (отжатие кнопки), приведет к удалению столбца параметров из дерева шаблонов.


Поиск

 На странице меню Поиск находятся команды Найти и Заменить, предназначенные для поиска и замены:

· наименований шаблонов;
· наименование файлов КОМПАС-3D, в которых хранятcя фрагменты (детали) шаблонов;
· наименование файлов Microsoft EXCEL, в которых хранятcя таблицы параметров шаблонов;
· наименование файлов, в которых хранятся схемы параметров шаблонов или заставка библиотеки.


Сервис

 На странице меню Сервис находятся команды:

· Настройка (предназначена для выбора свойств главного окна Менеджера шаблонов и самих шаблонов);
· Добавить библиотеку (предназначена для вставки ранее созданной библиотеки шаблонов в текущую библиотеку);
· Сформировать библиотеку (предназначена для создания новой библиотеки шаблонов из элемента текущей библиотеки).